package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.+title="(.*Zennolab.*?)">`)
var str = `border="0" ></div><a href="http://domain.com/" title="Текст заголовка Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст Zennolab заголовка">
border="0" ></div><a href="http://domain.com/" title="Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст заголовка">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}