$re = '/<a.+title="(.*Zennolab.*?)">/';
$str = 'border="0" ></div><a href="http://domain.com/" title="Текст заголовка Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст Zennolab заголовка">
border="0" ></div><a href="http://domain.com/" title="Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст заголовка">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);