import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.+title=\"(.*Zennolab.*?)\">";
final String string = "border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст заголовка Zennolab\">\n"
+ "border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст Zennolab заголовка\">\n"
+ "border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Zennolab\">\n"
+ "border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст заголовка\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}