re = /<a.+title="(.*Zennolab.*?)">/
str = 'border="0" ></div><a href="http://domain.com/" title="Текст заголовка Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст Zennolab заголовка">
border="0" ></div><a href="http://domain.com/" title="Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст заголовка">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end