// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a.+title="(.*Zennolab.*?)">"#).unwrap();
let string = "border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст заголовка Zennolab\">
border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст Zennolab заголовка\">
border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Zennolab\">
border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст заголовка\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}