using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.+title=""(.*Zennolab.*?)"">";
string input = @"border=""0"" ></div><a href=""http://domain.com/"" title=""Текст заголовка Zennolab"">
border=""0"" ></div><a href=""http://domain.com/"" title=""Текст Zennolab заголовка"">
border=""0"" ></div><a href=""http://domain.com/"" title=""Zennolab"">
border=""0"" ></div><a href=""http://domain.com/"" title=""Текст заголовка"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}