# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^domressult:\s+\"([^\"]+?)(\".*)/domressult: "\1 -d bbb\2/g;t' <<< "domressult: \"-d aaa -d bbb -d CCC\" # coment"