using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^domressult:\s+\""([^\""]+?)(\"".*)";
string substitution = @"domressult: ""\1 -d bbb\2";
string input = @"domressult: ""-d aaa -d bbb -d CCC"" # coment";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}