// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^domressult:\s+\"([^\"]+?)(\".*)"#).unwrap();
let string = "domressult: \"-d aaa -d bbb -d CCC\" # coment";
let substitution = "domressult: \"\\1 -d bbb\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}