import Foundation
let pattern = #"^domressult:\s+\"([^\"]+?)(\".*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"domressult: "-d aaa -d bbb -d CCC" # coment"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"domressult: "\1 -d bbb\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)