const regex = /^domressult:\s+\"([^\"]+?)(\".*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^domressult:\\s+\\"([^\\"]+?)(\\".*)', 'g')
const str = `domressult: "-d aaa -d bbb -d CCC" # coment`;
const subst = `domressult: "\1 -d bbb\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);