package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^domressult:\s+\"([^\"]+?)(\".*)`)
var str = `domressult: "-d aaa -d bbb -d CCC" # coment`
var substitution = "domressult: "\1 -d bbb\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}