re = /^domressult:\s+\"([^\"]+?)(\".*)/
str = 'domressult: "-d aaa -d bbb -d CCC" # coment'
subst = 'domressult: "\\1 -d bbb\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result