#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^domressult:\s+\"([^\"]+?)(\".*)"
Local $sString = "domressult: "-d aaa -d bbb -d CCC" # coment"
Local $sSubst = "domressult: "\1 -d bbb\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)