#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)"
Local $sString = "www.1edisource.com/ediresources/edinews.aspx?urlid=123" & @CRLF & _
"www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj" & @CRLF & _
"www.1edisource.com/ediresources/edinews.aspx" & @CRLF & _
""
Local $sSubst = "resources/edi-tips$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)