import Foundation
let pattern = #"(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
www.1edisource.com/ediresources/edinews.aspx?urlid=123
www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/edinews.aspx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"resources/edi-tips$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)