use strict;
my $str = 'www.1edisource.com/ediresources/edinews.aspx?urlid=123
www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/edinews.aspx
';
my $regex = qr/(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)/ip;
my $subst = 'resources/edi-tips$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";