const regex = /(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)EDIResources\\\/EDINews\\.aspx(\\?urlid=([a-zA-Z0-9_.-]+).*)', 'ig')
const str = `www.1edisource.com/ediresources/edinews.aspx?urlid=123
www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/edinews.aspx
`;
const subst = `resources/edi-tips$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);