// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)").unwrap();
let string = "www.1edisource.com/ediresources/edinews.aspx?urlid=123
www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/edinews.aspx
";
let substitution = "resources/edi-tips$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}