package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)`)
var str = `www.1edisource.com/ediresources/edinews.aspx?urlid=123
www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/edinews.aspx
`
var substitution = "resources/edi-tips$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}