import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)EDIResources\\/EDINews\\.aspx(\\?urlid=([a-zA-Z0-9_.-]+).*)";
final String string = "www.1edisource.com/ediresources/edinews.aspx?urlid=123\n"
+ "www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj\n"
+ "www.1edisource.com/ediresources/edinews.aspx\n";
final String subst = "resources/edi-tips$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}