re = /(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)/i
str = 'www.1edisource.com/ediresources/edinews.aspx?urlid=123
www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj
www.1edisource.com/ediresources/edinews.aspx
'
subst = 'resources/edi-tips$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result