# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)EDIResources\/EDINews\.aspx(\?urlid=([a-zA-Z0-9_.-]+).*)"
test_str = ("www.1edisource.com/ediresources/edinews.aspx?urlid=123\n"
"www.1edisource.com/ediresources/edinews.aspx?urlid=123&gclid=jjj\n"
"www.1edisource.com/ediresources/edinews.aspx\n")
subst = "resources/edi-tips$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.