# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?-s)(200 см<\/name>\R.*?\/)xx\//$1D-200\//gm;t' <<< "Пример:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>
Нужно:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>"