package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?-s)(200 см</name>\R.*?/)xx/`)
var str = `Пример:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>
Нужно:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>`
var substitution = "$1D-200/"
fmt.Println(re.ReplaceAllString(str, substitution))
}