# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?-s)(200 см</name>\R.*?/)xx/"
test_str = ("Пример:\n"
"<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>\n"
"<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>\n\n"
"Нужно:\n"
"<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>\n"
"<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>")
subst = "$1D-200/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.