re = /(?-s)(200 см<\/name>\R.*?\/)xx\//m
str = 'Пример:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>
Нужно:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>'
subst = '$1D-200/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result