import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?-s)(200 см</name>\\R.*?/)xx/";
final String string = "Пример:\n"
+ "<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>\n"
+ "<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>\n\n"
+ "Нужно:\n"
+ "<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>\n"
+ "<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>";
final String subst = "$1D-200/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}