#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?-s)(200 см</name>\R.*?/)xx/"
Local $sString = "Пример:" & @CRLF & _
"<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>" & @CRLF & _
"<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>" & @CRLF & _
"" & @CRLF & _
"Нужно:" & @CRLF & _
"<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>" & @CRLF & _
"<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>"
Local $sSubst = "$1D-200/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)