// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?-s)(200 см</name>\R.*?/)xx/").unwrap();
let string = "Пример:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>
Нужно:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>";
let substitution = "$1D-200/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}