use strict;
my $str = 'Пример:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/xx/</url>
Нужно:
<name>Матрас Dimax ОК Симпл Круглый диаметр 200 см</name>
<url>https://site.ru/matras-dimax-ok-simpl/D-200/</url>';
my $regex = qr#(?-s)(200 см</name>\R.*?/)xx/#mp;
my $subst = '$1D-200/';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";