# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(this is) test (?<test>testValue)/$1 test <!<mode:\\U>%&${test}&%>/gm;t' <<< "this is test testValue"