const regex = new RegExp('(this is) test (?<test>testValue)', 'gm')
const str = `this is test testValue`;
const subst = `$1 test <!<mode:\\U>%&${test}&%>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);