$re = '/(this is) test (?<test>testValue)/m';
$str = 'this is test testValue';
$subst = "$1 test <!<mode:\\U>%&${test}&%>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;