import re
regex = re.compile(r"(this is) test (?<test>testValue)", flags=re.MULTILINE)
test_str = "this is test testValue"
subst = "$1 test <!<mode:\\\\U>%&${test}&%>"
result = regex.sub(subst, test_str)
if result:
print(result)