using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(this is) test (?<test>testValue)";
string substitution = @"$1 test <!<mode:\\U>%&${test}&%>";
string input = @"this is test testValue";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}