// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(this is) test (?<test>testValue)").unwrap();
let string = "this is test testValue";
let substitution = "$1 test <!<mode:\\\\U>%&${test}&%>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}