use strict;
my $str = 'this is test testValue';
my $regex = qr/(this is) test (?<test>testValue)/mp;
my $subst = '$1 test <!<mode:\\\\U>%&${test}&%>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";