# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)//g;t' <<< "123-abcd 123-abcd&abcd-123"