// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)").unwrap();
let string = "123-abcd 123-abcd&abcd-123";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}