package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)`)
var str = `123-abcd 123-abcd&abcd-123`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}