#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)"
Local $sString = "123-abcd 123-abcd&abcd-123"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)