const regex = new RegExp('(?P<digit>\\d{3})-(?P<char>\\w{4})&(?P=char)-(?P=digit)', 'g')
const str = `123-abcd 123-abcd&abcd-123`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);