using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)";
string substitution = @"";
string input = @"123-abcd 123-abcd&abcd-123";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}