use strict;
my $str = '123-abcd 123-abcd&abcd-123';
my $regex = qr/(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";