$re = '/(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)/';
$str = '123-abcd 123-abcd&abcd-123';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;