# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0*(0\d+)/$1/gm;t' <<< "00099999325
1254
1230004
0001230004"