using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0*(0\d+)";
string substitution = @"$1";
string input = @"00099999325
1254
1230004
0001230004";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}