#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^0*(0\d+)"
Local $sString = "00099999325" & @CRLF & _
"1254" & @CRLF & _
"1230004" & @CRLF & _
"0001230004"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)