package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)(?:(?:=|:)\w+)?$`)
var str = `https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true
dev.testapi.com/api/v1/properties?id=xyz&blabla
dev.testapi.com/api/v1/properties?id=xyz
dev.testapi.com/api/v1/properties?id=xyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}